Fivetran: Some Hubspot Connection Syncs are failing

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.

Incident Summary

Description:
We identified an issue where the Hubspot connections are failing with "Failed to sync 1 endpoint: - DEAL: Null primary key found while syncing table schema_name.deal. Primary Key dealId is null in the object."

Timeline:
The issue began on 26 January around 04:50:00 AM UTC and was resolved on 26 January around 08:10:00 AM UTC.

Cause:
HubSpot connections were failing due to recent code changes.

Resolution:
The fix was deployed. After deployment, HubSpot connections sync successfully.
Posted Jan 26, 2026 - 08:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 26, 2026 - 08:00 UTC

Update

We identified that Hubspot connections are failing with "Failed to sync 1 endpoint: - DEAL: Null primary key found while syncing table schema_name.deal. Primary Key dealId is null in the object."
This was caused by a recent code change. A hotfix is being deployed to resolve the issue.
Posted Jan 26, 2026 - 06:55 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jan 26, 2026 - 06:45 UTC
This incident affected: Sales connectors (HubSpot).