Fivetran: Mutliple Amazon Ads connection syncs are faling with 'operationTimestamp' NullPointerException

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that success rates are returning to normal levels, and affected connections are syncing successfully.

Incident Summary

Description:
We identified an issue with Amazon Ads connections that caused syncs to fail with a 'operationTimestamp' NullPointerException.

Timeline:
This issue began on 18-05-2026 04:49 AM UTC and was resolved on 18-05-2026 08:08 AM UTC.

Cause:
A recent change related to Operations Consolidation introduced a regression, causing a null pointer exception and resulting in sync failures for affected Amazon Ads connectors.

Resolution:
We reverted the change that was causing the issue, after which syncs started succeeding.
Posted May 18, 2026 - 08:38 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 18, 2026 - 07:45 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted May 18, 2026 - 07:05 UTC
This incident affected: Marketing connectors (Amazon Ads).