Fivetran: PostgreSQL Connections Using RDS Proxy Are Failing with the Error: The source database does not support a provided lock_timeout parameter

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that error rates have returned to normal levels, and the service is operating as expected.

Incident Summary
Description:
We identified an issue with the PostgreSQL Connections Using RDS Proxy Failing with the Error: The source database does not support a provided lock_timeout parameter

Timeline:
The issue began on 26/03/2026 at 05:40 UTC and was resolved on 26/03/2026 at 07:45 UTC.

Cause:
The issue was caused by a recent code change introducing a bug from Fivetran.

Resolution:
The bug was fixed and the connection services were restored.
Posted Mar 26, 2026 - 08:10 UTC

Monitoring

We have released a fix to resolve the identified issues. Affected services are beginning to recover, and we are closely monitoring the system to ensure continued stability.
Posted Mar 26, 2026 - 07:38 UTC

Update

We have identified the root cause of the current errors as a recent code change. Our engineering team is currently developing a fix to restore full service.
Posted Mar 26, 2026 - 06:15 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Mar 26, 2026 - 05:43 UTC
This incident affected: Systems (General Services) and Database connectors (Google Cloud SQL for PostgreSQL, PostgreSQL).