Fivetran: Multiple SAP connectors are failing with "Unknown failure. Unable to establish connection to SAP source" error.

Incident Report for Fivetran

Resolved

This incident has been resolved. We’ve observed that instance rates have returned to normal levels and the affected connectors are syncing successfully.

For a few connectors where the sync frequency is set to manual, the last sync is still showing as failed. Please trigger a manual sync, and the next sync should complete successfully.

Incident Summary:

Description:
SAP ERP on HANA connectors are failing with "Unknown failure. Unable to establish connection to SAP source" error.

Timeline:
The issue began on 23 December around 10:12 PM UTC and was resolved on 24 December around 05:55 AM UTC.

Cause:
The issue was caused by a bug introduced in a recent code change.

Resolution:
The changes were reverted, which restored successful syncs.
Posted Dec 24, 2025 - 07:56 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Dec 24, 2025 - 06:32 UTC

Update

We are continuing to work on a fix for this issue.
Posted Dec 24, 2025 - 02:53 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Dec 24, 2025 - 02:35 UTC
This incident affected: Database connectors (SAP ERP on HANA).