3rd Party: Apple Search Ads: Syncs failing from "Unknown Error Occurred" due to 503 Service Unavailabe

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We identified an issue with Apple Search Ads connector failing with 503 Errors which resulted in sync failures.

Timeline:
This issue began on Aug 15 at 21:55 UTC and was resolved on Aug 17 at 9:30 AM UTC.

Cause:
Due to third party service unavailability

Resolution:
This seems to have been resolved on Apple's end, and the connections are now syncing successfully
Posted Aug 17, 2025 - 14:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2025 - 11:35 UTC

Update

Our team is working with the Apple support team to investigate.
Posted Aug 16, 2025 - 18:58 UTC

Update

We’ve reached out to the Apple support team to investigate the 503 response being returned from their endpoint.
Posted Aug 16, 2025 - 04:57 UTC

Identified

The Apple Search Ads API is returning "503 Service Temporarily Unavailable" when making requests.

We are working to identify the cause of the failures.
Posted Aug 15, 2025 - 21:55 UTC