This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.
Incident Summary: Description:
Some connectors failed with a "Failed verifying trust anchor signature" exception.
Timeline:
This issue began on May 12, 2025, around 9 PM UTC and was fully resolved on May 17, 2025, around 10 PM UTC.
Cause:
A scheduled cleanup task accidentally removed the certificates resulting in the revalidate TLS certificate errors.
Resolution:
Fivetran restored the certificates that fixed the issue.
Posted May 13, 2025 - 22:04 UTC
Monitoring
We have observed that many connectors are starting to recover. We are continuing to investigate and will provide additional updates as we have them.
Posted May 13, 2025 - 18:45 UTC
Update
We are currently investigating an issue that is causing some connectors to fail with a "TLS verification failed" exception.
Posted May 13, 2025 - 17:04 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 13, 2025 - 16:59 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted May 13, 2025 - 16:39 UTC
This incident affected: Database connectors (Amazon Aurora MySQL, Amazon Aurora PostgreSQL, Azure Database for PostgreSQL, Azure SQL Database, Google Cloud SQL for PostgreSQL, MongoDB, Amazon RDS for PostgreSQL, Elastic Cloud, Self Hosted Elasticsearch, BigQuery, Firebase, CockroachDB), Marketing connectors (Adobe Analytics, Facebook Ads, Facebook Pages, Google Campaign Manager 360, Google Analytics 4, Google Ads), Productivity connectors (Airtable), Finance connectors (Braintree), and Log connectors (Fivetran Platform).