Fivetran: Some Postgres WAL connectors failed due to NumberFormatException
Incident Report for Fivetran
Resolved
This incident has been resolved.
Posted Feb 29, 2024 - 14:42 UTC
Update
The fix has been rolled out to all connectors and connectors are beginning to recover. We will continue to monitor.
Posted Feb 29, 2024 - 13:27 UTC
Update
We have verified the fix and are rolling out the fix to all the connectors.
Posted Feb 29, 2024 - 12:21 UTC
Update
We are verifying another fix and after verification, we will do the rollout to all the connectors. We have found a recent change which caused the issue and rolled it back.

To provide more details on the issue, the error being seen is the below.
For input string: "FFFFFFFFB835BF10" under radix 16
Posted Feb 29, 2024 - 11:14 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 29, 2024 - 07:02 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 29, 2024 - 06:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 29, 2024 - 06:37 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Feb 29, 2024 - 06:13 UTC
This incident affected: Database connectors (Amazon Aurora PostgreSQL, PostgreSQL, Amazon RDS for PostgreSQL).