Fivetran: Database Connectors Using Teleport Sync Are Rescheduling to Handle Failures
Incident Report for Fivetran
Resolved
We have resolved this incident.

Incident Summary

Description:
We encountered an issue where database connectors using Teleport Sync as the sync mechanism were rescheduling to handle failures.

Timeline:
The issue started on January 20, 2025, at 10:35 UTC and was resolved on January 21, 2025, at 04:00 UTC.

Cause:
The issue was caused by an internal error in the connector code.

Resolution:
The issue has been fully resolved, and all affected connectors have returned to normal functionality.
Posted Jan 21, 2025 - 04:00 UTC
Monitoring
The fix was released as a hotfix and we are currently monitoring connectors to ensure the issue is resolved.
Posted Jan 20, 2025 - 14:32 UTC
Update
We have prepared a fix for the issue and we anticipate this will be released in our next deployment at 15:00 UTC.
Posted Jan 20, 2025 - 12:13 UTC
Identified
The issue has been identified and we are working to resolve it.

The re-syncs are being triggered as we are unable to read previous snapshots generated by Teleport.
Posted Jan 20, 2025 - 10:35 UTC
This incident affected: Systems (General Services).