Fivetran: Hybrid connections are delayed

Incident Report for Fivetran

Resolved

Description:

We identified connection issues affecting dependency retrieval during the build process for Hybrid Connector images. Specifically, requests to external package sources were failing, resulting in build disruptions.

Impact:

Customers using Hybrid Deployment may have experienced failures when attempting to build or update connector images during this period.

Timeline:

Start Time: 2026-05-04 13:43 UTC
End Time: 2026-05-04 14:57 UTC

Root Cause:

The issue was caused by an inability to fetch required dependencies from Ubuntu Launchpad and the Ubuntu archive, which prevented successful image builds.

Resolution:

 We mitigated the issue by reverting to stable, previously built images, restoring normal functionality for Hybrid Connector deployments.
Posted May 04, 2026 - 18:21 UTC

Monitoring

A workaround has been applied. We've rolled back the image affecting Hybrid Deployment connectors, and syncs have resumed. Our team is working on a permanent fix.
Posted May 04, 2026 - 15:30 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted May 04, 2026 - 14:15 UTC
This incident affected: Systems (General Services).