3rd Party: Reddit Ads connectors failing with Reconnect task: "400 Field 251 not found in config"

Incident Report for Fivetran

Resolved

Incident Summary
Description:
We encountered an issue affecting Reddit_ads connectors, syncs were failing with with Reconnect task: "400 Field 251 not found in config"

Timeline:
This issue first started occurring 2025-07-15, 17:00 UTC+0 and was resolved on 2025-07-16, 08:00 UTC+0

Root Cause: We have identified a third-party issue with the Reddit Ads API. The API is returning a 400 error with the message: "Field 251 not found in config", indicating a problem related to the CONVERSION_CUSTOM_AVG_VALUE field.

Resolution:
We resolved the issue by deploying a fix and excluded the field from requests.
Posted Jul 16, 2025 - 12:35 UTC

Update

Monitoring has identified that some Connections are recovering. There have also been some that have continued to fail. We are investigating these Connections that are continuing to fail.
Posted Jul 16, 2025 - 09:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2025 - 06:13 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 15, 2025 - 22:44 UTC

Identified

We have identified an issue where Reddit Ad connectors are failing with a Reconnect task with the message: : "400 Field 251 not found in config".

We are currently investigating in more detail and will provide additional updates accordingly.
Posted Jul 15, 2025 - 22:30 UTC