Apple App Store Connectors are Failing
Incident Report for Fivetran
Resolved
We have sent out a separate email communication mentioning the current status and next action items related to this incident.
Posted Feb 19, 2021 - 08:18 UTC
Update
1. For those customers that are unable to login to their Apple ID, or their account has been deactivated:
Please reach out to Apple through their chat feature by navigating to https://getsupport.apple.com/, and they will restore your account.

2. App Analytics is not syncing:
Due to changes in Apple’s API, we will temporarily not be syncing the endpoint for App Analytics and Reviews. At present, the connector will continue to sync sales and finance-related reports.
Posted Feb 16, 2021 - 22:02 UTC
Update
Some iTunes connectors are seeing this error:

Invalid username and password.{code=108, message='Invalid username and password. Change values and try again.'}

Please generate a new app specific password on the apple side and update it the fivetran setup form. The invalid username and password here is referencing the invalid username and app specific password. See this Apple support doc on how to reset the app specific password:
https://support.apple.com/en-in/HT204397
Posted Feb 13, 2021 - 21:34 UTC
Update
We are working with Apple support to gain more understanding about the error messages being received.
Posted Feb 11, 2021 - 03:47 UTC
Update
The error "MessageBodyReader" is occurring because we expect a JSON response on hitting the endpoint "analytics/api/v1/app-info/app", but Apple has started sending a HTML response and we are unable to fetch all the app details.

We are getting in touch with Apple support team to understand the issue
Posted Feb 10, 2021 - 11:32 UTC
Investigating
Apple App Store connectors that are using 2FA are failing on the error "MessageBodyReader not found for media" and are getting rescheduled with "Too many verification codes submitted" message. We are currently investigating this
Posted Feb 10, 2021 - 09:38 UTC
This incident affected: Fivetran Services (Replication Servers).