Fivetran: Marketo Connections Experiencing Sync Failures

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that success rates are returning to normal levels and affected connections are syncing successfully.

Incident Summary

Description:
Affected Marketo connections experienced sync failures with error PROGRAM_MEMBERSHIP: fields not specified

Timeline:
This issue began on 2025-05-08 16:00:00 UTC and was resolved on 2025-05-10 12:30:00 UTC.

Cause:
A recent connector change unintentionally impacted requests to the affected endpoint, resulting in sync failures.

Resolution:
The change introducing the issue was reverted, and the fix was successfully deployed.
Posted May 10, 2026 - 12:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 10, 2026 - 12:30 UTC

Identified

The Marketo connections are failing with “PROGRAM_MEMBERSHIP: fields not specified” Error. The issue has been identified and we are working to resolve it.
Posted May 10, 2026 - 10:10 UTC
This incident affected: Marketing connectors (Marketo).