Fivetran: We are encountering the following error on the Fivetran dashboard when triggering a sync manually or via the Fivetran API: "Sorry, we have had an unexpected issue: Server error"

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We identified an issue for manual syncs triggered via Dashboard and API, which resulted in "Invalid status code 500" error.

Timeline:
Incident start date: 15 May 06:48 (UTC)
Incident end date: 15 May 16:46 (UTC)

Cause:
We encountered a pipeline naming configuration exception during a recent code change. This resulted in an "Invalid status code 500" error.

Resolution:
The code change was reverted. All manual syncs triggered via Dashboard and API have returned to normal functionality.
Posted May 15, 2025 - 17:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2025 - 17:00 UTC

Update

We've observed that this issue is also affecting our dbt transformations, and we are now seeing the following errors when triggering a sync manually or via API.
- exception_cause_cause_message=NOT_FOUND: workflow execution already completed
- exception_cause_cause_message=NOT_FOUND: workflow not found for ID: xxxx

Our team is currently working on implementing a fix to address this.
Posted May 15, 2025 - 09:42 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted May 15, 2025 - 07:08 UTC
This incident affected: Web Application.