3rd Party: Aircall connectors are experiencing 400 errors on the Numbers endpoint

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.

Incident Summary
Description: Some AirCall connectors were experiencing sync failures due to the following error on the Numbers endpoint:
{"error":"Bad Request","troubleshoot":"Line: 720xx has a welcome message inside IVR"}

Timeline: This issue began on July 04, 2025, 09:56 AM UTC and was resolved on Jul 05, 2025, 11:28 AM UTC

Cause: One of the responses from the Numbers endpoint included an IVR message with a nested welcome message, which didn't match the expected format and caused a 400 error from the source end

Resolution: We implemented a fix to gracefully handle this error by skipping the NUMBER endpoint and alerting users that IVR configurations must be completed.
Posted Jul 05, 2025 - 15:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 05, 2025 - 12:15 UTC

Identified

As per the update from Aircall, the 400 Bad Request error on the /numbers endpoint is due to a nested welcome message within the IVR message field, which violates their expected payload structure; we’re aligning with their guidance to make the necessary changes and are also evaluating alternate solutions.
Posted Jul 05, 2025 - 10:09 UTC

Investigating

The numbers endpoint is failing with a 400 Bad Request for some Aircall connectors. We have contacted the source support regarding this.
Posted Jul 05, 2025 - 06:56 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jul 05, 2025 - 05:25 UTC
This incident affected: Marketing connectors (Aircall).