3rd Party: Pipedrive connections are failing with 504 gateway error

Incident Report for Fivetran

Resolved

This incident has been resolved by the Pipedrive team. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.

Incident Summary
Description:
There was an incident with Pipedrive because of which the Fivetran Pipedrive connections started failing with a 504 gateway error.

Timeline:
Incident start date: 2025-06-10 06:28 UTC
Incident end date: 2025-06-10 14:38 UTC

Cause:
The issue was caused by an incident on Pipedrive's side, affecting many components, including the REST APIs as well. Pipedrive status page: https://status.pipedrive.com

Resolution:
The Pipedrive team implemented a fix that successfully resolved the issue.
Posted Jun 10, 2025 - 15:18 UTC

Monitoring

A fix has been implemented from Pipedrive team. We're currently monitoring the connector performance.
Posted Jun 10, 2025 - 13:45 UTC

Update

The issue has been identified from Pipedrive with the Pipedrive Web App and is actively worked upon by the team. The live status is made available on the Pipedrive status page here: https://status.pipedrive.com/
Posted Jun 10, 2025 - 10:01 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jun 10, 2025 - 07:35 UTC
This incident affected: Sales connectors (Pipedrive).