3rd Party: Talkdesk connectors failing with "Unknown sync failures" on the dashboard
Incident Report for Fivetran
Resolved
TalkDesk has reported that API behavior has returned to normal. All connectors are syncing successfully.
Posted Apr 26, 2024 - 23:44 UTC
Update
We see the majority of connectors have recovered but we are continuing to monitor the remaining connectors.
Posted Apr 26, 2024 - 16:28 UTC
Monitoring
We have received an update from Talkdesk support that their API response times have now returned to normal. We will continue to monitor syncs to see if this resolves the issue.
Posted Apr 26, 2024 - 13:13 UTC
Identified
We had observed that some syncs were passing with the workaround on our end but the connectors are now failing again with the same error message.

We have reached out to Talkdesk support again regarding this inconsistency. We have received a response indicating that the issue has not been completely resolved with the Explore API. They are working on implementing a permanent solution which should help resolve the issue.
Posted Apr 26, 2024 - 09:02 UTC
Update
Talkdesk has confirmed that mitigation measure have been applied. We've seen several connectors sync successfully. We are continuing to monitor connectors that have failed syncs.
Posted Apr 25, 2024 - 22:10 UTC
Monitoring
We have now applied a workaround for the issue and we will be monitoring for continued failure. Currently running syncs will need to be restarted to avail of the new logic.

We are continuing to communicate with Talkdesk regarding the API issues.
Posted Apr 25, 2024 - 15:36 UTC
Update
We have prepared a workaround on our end that should reduce the amount of data we request in a single API call along with increasing the number of retries and we are planning on releasing this soon.

We have also received communication from Talkdesk support on this issue. They are aware of a transient issue with the Explore API yesterday afternoon (US EST). They mentioned that they had applied measures to mitigate the issue but this does not seem to have resolved the issues with the connector. We will continue to communicate with them on this.
Posted Apr 25, 2024 - 14:13 UTC
Update
We are still waiting for feedback from Talkdesk support. In the meantime, we are exploring a reduction in the size of the data window we are requesting from the API along with adding additional retries. This may allow us to work around the issue.
Posted Apr 25, 2024 - 11:21 UTC
Identified
Talkdesk connectors are failing on the
CONTACT_CALL and RING_ATTEMPT tables. The API endpoints for these tables are returning unexpected 404 errors. We’re working with the Talkdesk team to determine the solution.
Posted Apr 24, 2024 - 22:14 UTC
Investigating
The dashboard error for the failing connectors is as below:

We couldn't sync * out of the 31 primary endpoint(s). We were unable to sync data for the following tables: ***. Error details: {[id:29] URL: *** is not responding with correct response after specific retries and giving status code [404] and status message [{ "code" : "1020008", "error_code" : "1020008", "message" : "Report file not found"}]}
Posted Apr 24, 2024 - 15:45 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Apr 24, 2024 - 15:43 UTC
This incident affected: Support connectors (Talkdesk).