Fivetran: Some Reddit_ads connectors are failing with the error "Too Many Requests"

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
Starting June 21, 2025, Reddit_ads connectors were failing with the error "Too Many Requests".

Timeline:
Incident Start Time: June 21, 00:30 (UTC+0)
Incident End Time: June 21, 13:00 (UTC+0)

Cause:
Triggering the historical re-sync for Reddit Ads resulted in a 'Too Many Requests' error for some connections.

Resolution:
Many connections have been recovered automatically.
Some connections got stuck, so we are triggering them manually to complete a sync.
Posted Jun 21, 2025 - 17:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 21, 2025 - 15:37 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jun 21, 2025 - 11:00 UTC
This incident affected: Marketing connectors (Reddit Ads).