This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.
Incident Summary
Issue: Oracle Connector using Binary Log Reader are failing due to bad cast of Oracle2State to Oracle2StateImpl.
Timeline: This issue began on Jan 27, 2026, at 01:30 UTC and was resolved on Jan 27, 2025, at 06:30 UTC.
Root Cause: The issue occurred due to a recent code change made in the Oracle connector.
Resolution: The recent changes have been reverted, and the connectors have started recovering.
Posted Jan 27, 2026 - 06:38 UTC
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Jan 27, 2026 - 05:32 UTC
Update
We are aware of an issue with our Oracle connectors where syncs are failing due to bad cast of Oracle2State to Oracle2StateImpl. A possible root cause has already been identified, and we are working to raise a solution.
Posted Jan 27, 2026 - 02:52 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Jan 27, 2026 - 02:40 UTC
This incident affected: Database connectors (Oracle).