Incident: 3rd Party: Some Recharge Connections Failing with HTTP 422 Error
Description: An issue was identified affecting Recharge connections, where syncs were failing with an HTTP 422 error. The affected endpoint is /customers//delivery_schedule, which is a child of the Customer entity. The source server returned a 422 response with the following message:
{"errors": {"future_interval": ["Not a valid integer."]}}
Timeline: Issue started on 2025-10-31 06:30 UTC and resolved on November 2nd 6:00 UTC
Cause: The failures occurred due to invalid responses from the source server for the customer_delivery_schedule entity, resulting in sync errors in Fivetran.
Resolution: The issue was resolved automatically without any code changes.
Posted Nov 02, 2025 - 22:10 UTC
Monitoring
We are skipping sync for the affected tables, which are child tables of the 'Customer' table. We are also reaching out to the Recharge team to gain a better understanding of the issue and are actively monitoring it to ensure a stable resolution.
Posted Nov 02, 2025 - 18:34 UTC
Identified
We have identified an issue affecting some Recharge connections, where syncs are failing with an HTTP 422 error. The affected endpoint is "/customers//delivery_schedule", a child of the 'Customer' entity. The source server is returning a 422 response with the message: "{"errors":{"future_interval":["Not a valid integer."]}}"
Posted Nov 02, 2025 - 15:20 UTC
This incident affected: Finance connectors (ReCharge).