3rd Party: Multiple Linear Connections Experiencing Sync Failures on the Organization Endpoint

Incident Report for Fivetran

Resolved

The issue has been fully resolved, and Linear connections have resumed syncing normally. The source has reinstated the previously removed fields, restoring expected behavior.

Incident Summary

Description:
Linear connections were experiencing sync failures on the Organization endpoint, returning a GRAPHQL_VALIDATION_FAILED error.

Timeline:
The issue began on November 19 at 4:20 PM UTC and was resolved on November 19 at 6:24 PM UTC.

Cause:
The Linear source removed the allowMembersToInvite field from the Organization endpoint, which resulted in a 400 GRAPHQL_VALIDATION_FAILED error.
Source reference: https://studio.apollographql.com/public/Linear-API/variant/current/changelog

Resolution:
The Linear team re-added the allowMembersToInvite field in their API configuration, resolving the validation error. As a result, we did not implement any changes to exclude this field. All affected connections have now resumed normal syncing.
Posted Nov 19, 2025 - 19:52 UTC

Update

We have identified that the source API is now returning a 400 GRAPHQL_VALIDATION_FAILED error when the allowMembersToInvite field is included in Organization endpoint requests, resulting in sync failures. This field previously worked without issues.
We are updating our linear connector to exclude this field, allowing affected connections to resume syncing.
Posted Nov 19, 2025 - 19:09 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Nov 19, 2025 - 18:45 UTC
This incident affected: Engineering connectors (Linear).