Fivetran: SQL Server TELEPORT and Epic CSA Connector POTENTIAL Failures Due to Unsupported Type in VIEW tables

Incident Report for Fivetran

Resolved

This incident has been resolved.

Incident Summary

Description:

We identified an issue affecting the SQL Server (Teleport) and Epic CSA connectors, where syncs were failing with the following error:

java.lang.IllegalArgumentException: No enum constant com.fivetran.integrations.sql_server.connector.schema.SqlServerType.SYSNAME

Timeline:

The issue began on April 2, 2026, at 15:07 UTC and was resolved on April 2, 2026, at 20:49 UTC.

Cause:

A recent deployment introduced an issue impacting views in the Epic CSA and SQL Server (Teleport) connectors.

Resolution:

The deployment was rolled back, and a hotfix was applied, restoring normal operations.
Posted Apr 02, 2026 - 21:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2026 - 21:03 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 02, 2026 - 18:37 UTC

Identified

We identified a potential issue affecting the SQL Server (Teleport) and Epic CSA connectors, where syncs are failing with the following error.

The action failed after 1 attempt(s), the failures were:1) java.lang.IllegalArgumentException: No enum constant com.fivetran.integrations.sql_server.connector.schema.SqlServerType.SYSNAME
Posted Apr 02, 2026 - 17:45 UTC
This incident affected: Database connectors (SQL Server, Epic Clarity).