Fivetran: HubSpot Connections Failing with NullPointerException for email_campaign

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary

Description:
We identified an issue impacting Hubspot connections, which resulted in syncs failing with the following error:
"Failed to sync 1 endpoint(s) with error: {email_campaign=java.lang.NullPointerException: Cannot invoke <>"

Timeline:
This issue began on 2026-03-03 at 18:00 UTC and was resolved on 2026-02-25 at 22:00 UTC.

Cause:
This was determined to be caused by a change in connector sync behavior.

Resolution:
The changes to the sync strategy have been reverted and connections are now syncing successfully.
Posted Mar 03, 2026 - 22:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2026 - 22:05 UTC

Update

We have identified the root cause of the issue: recent changes to the HubSpot connector introduced a NullPointerException in the email_campaign object, resulting in sync failures, and we are actively working on a hotfix to resolve it.
Posted Mar 03, 2026 - 19:52 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Mar 03, 2026 - 18:25 UTC
This incident affected: Sales connectors (HubSpot).