Fivetran: Some Public API Endpoints Unavailable

Incident Report for Fivetran

Resolved

Description:
We identified an issue affecting only the following three public API endpoints, where requests are failing with a 500 Internal Server Error:

connections/{connection_id}/sync
connections/{connection_id}/schemas/reload
connections/{connection_id}/schemas/{schema}/tables/{table}/columns

Timeline:
This issue began on May 29th at 09:46 UTC and was resolved on May 29th at 11:58 UTC.

Cause:
The issue was caused by the recent updates to the API Library dependencies.

Resolution:
The updates have been reverted to resolve the issue.
Posted May 29, 2025 - 16:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 29, 2025 - 15:42 UTC

Identified

We identified an issue affecting the following three public API endpoints, where requests are failing with a 500 Internal Server Error:

connections/{connection_id}/sync
connections/{connection_id}/schemas/reload
connections/{connection_id}/schemas/{schema}/tables/{table}/columns
Posted May 29, 2025 - 15:12 UTC
This incident affected: Fivetran API.