Fivetran: Multiple Oracle Connections Failing With "ORA-00942: table or view does not exist" Error

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connections are syncing successfully.

Incident Summary

Description:
We identified an issue with Oracle connections, which resulted in syncs failing with a 'ORA-00942: table or view does not exist' error.

Timeline:
This issue began on February 18th, at around 5:45 AM UTC and was resolved on February 18th, at around 8:45 AM UTC

Cause:
Recent code changes initiated queries to the sys.tabpart$ system table. Consequently, since the required grant was missing, all subsequent connection syncs resulted in failure.

Resolution:
We have restored connection sync stability by reverting a recent code change. All systems are now operating normally.
Posted Feb 18, 2026 - 10:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2026 - 09:18 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 18, 2026 - 06:45 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Feb 18, 2026 - 06:40 UTC
This incident affected: Database connectors (Oracle, Oracle EBS, Oracle RDS).