Hubspot - Reason: Error reading entity from input stream.
Incident Report for Fivetran Inc
Postmortem

Root Cause:

topicIds field in CalendarEvent had an incorrect type; it was String but should have been List<String>.

Hubspot made a recent change in which an empty list is being returned in lieu of null. We were able to confirm this from the docs as well as from our sample test data, which shows this field having a null value.

Timeline:

06:10:57 PDT - First occurrence of the error above

10:02:00 PDT - Outage reported on the Hubspot status page.

18:35:19 PDT - Fix was deployed

Resolution:

Changed the type of topicIds from String to List<String>.

Posted Dec 07, 2020 - 09:50 UTC

Resolved
Connectors are running successfully now.
Posted Dec 03, 2020 - 05:56 UTC
Monitoring
The fix is now live and affected connectors are returning to normal. We're monitoring affected connectors for unexpected errors.

No data loss is expected at this time.
Posted Dec 03, 2020 - 03:02 UTC
Update
Our QA team is currently revising the original fix to ensure it's deployed successfully.

The new ETA for this fix going live is 8PM PDT.
Posted Dec 03, 2020 - 00:01 UTC
Identified
We've identified the root cause as Hubspot suddenly changing the format of the field 'topidIds'.

Our sync expected this to be a string, and Hubspot changed to returning a list of 'topidIds'.

We are rolling out a fix now. We expect this to be live by 5PM PDT.
Posted Dec 02, 2020 - 23:09 UTC
Investigating
Some Hubspot connector users are noticing failed syncs with 'Error reading entity from input stream.'

We are currently investigating the cause.
Posted Dec 02, 2020 - 21:29 UTC
This incident affected: Fivetran Services (Replication Servers).