3rd Party: Multiple Twitter Ads Connections Sync Failures Due to Access Level/Permission Error (Code 453)

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that error rates have returned to normal levels, and the service is operating as expected.

Incident Summary

Description:
We identified an issue affecting multiple Twitter Ads Connections Sync Failures Due to Access Level/Permission Error (Code 453)

Timeline:
The issue began on 2026-04-21 20:43 UTC and was resolved on 2026-04-22 02:23 UTC.

Cause:
X API started to fail report GZIP file authenticated download requests.

Resolution:
Authentication has been removed from GZIP file download requests.
Posted Apr 22, 2026 - 03:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2026 - 00:25 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Apr 21, 2026 - 22:00 UTC
This incident affected: Marketing connectors (X Ads).