3rd Party: Klaviyo Connections Have Stopped Syncing “property_attribution” Data in the “EVENT” Table Since March 15th

Incident Report for Fivetran

Update

We are continuing to engage with Klaviyo support on the null `property_attribution` values within the latest version.

A partial re-sync is planned for this week to correct null records in March. Customer communications will be sent out before we proceed, as certain instances may experience extended sync times during the recovery.

If you require the `property_attribution` field to be populated immediately, please contact support.
Posted Mar 24, 2025 - 12:33 UTC

Monitoring

We are continuing to engage with Klaviyo support on the null `property_attribution` values within the latest version.

A partial re-sync is planned for the beginning of next week to correct null records in March. Customer communications will be sent out before we proceed, as certain instances may experience extended sync times during the recovery.

If you require the `property_attribution` field to be populated immediately, please contact support.
Posted Mar 22, 2025 - 10:08 UTC

Update

We continue to work on a fix that will be rolled out to all impacted customers over the coming days.
Posted Mar 20, 2025 - 16:57 UTC

Update

We have identified the root cause of the issue and are working on a fix that will be rolled out to all impacted customers over the coming days.
Posted Mar 19, 2025 - 22:33 UTC

Identified

We have identified an issue which has caused data to stop syncing to the “property_attribution” column in the “EVENT” table since March 15th.

This issue has been confirmed to be caused by an upgrade in the Klaviyo Connector to use Klaviyo API Version '2025-01-15'. This version has been identified to require a different configuration to retrieve the “property_attribution” data, and this configuration does not return data when applied to the queries to the API.

We are engaging with Klaviyo Support to understand the cause of the data not returning for the new API. We are also working on a solution to restore the sync of the “property_attribution” data and restore any data that has not synced since March 15th.
Posted Mar 19, 2025 - 18:01 UTC
This incident affects: Marketing connectors (Klaviyo).