Fivetran: Sync Failures on PayPal Transaction Tables Due to API Rate Limiting

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.

Incident Summary

Description:
We encountered an issue where PayPal connectors started failing due to an API rate limit issue

Timeline:
The issue started on Aug 03, 2025, at 08:30 UTC and was resolved on Aug 03, 2025, at 15:19 UTC

Cause:
The issue was caused due to sustained rate limiting from the source API endpoint (/v1/reporting/transactions) for all transaction-related tables (e.g, TRANSACTION and BALANCE).

Resolution:
We have initially disabled the balance endpoint to fix the issue. Later, we re-enabled the balance endpoint and added a logic to handle the rate limit more gracefully (Using ProActive Rate Limit and rescheduling the sync for 1 hour when rate limits are encountered) in order to resolve the issue.
Posted Aug 04, 2025 - 08:38 UTC

Monitoring

We have raised a fix to disable the affected endpoint "Balance" and we are monitoring the results.
Posted Aug 03, 2025 - 15:12 UTC

Identified

We have identified that the the failures are occurring on transaction-related tables (TRANSACTION, BALANCE, INCENTIVE, etc.) due to persistent rate limiting from the PayPal API endpoint /v1/reporting/transactions.
Posted Aug 03, 2025 - 11:15 UTC
This incident affected: Finance connectors (Paypal).