Fivetran: Amazon PostgreSQL Connectors Experiencing Sync Delays

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.

Description:
We identified an issue affecting multiple Postgresql connectors, resulting in sync delays due to a recent change.

Timeline:
This issue began on April 21 at 10:30 PM UTC and was resolved on April 22 at 9:00 AM UTC.

Cause:
A misconfiguration in a recent change for Postgresql connectors caused a sync delay.

Resolution:
The changes were reverted to restore normal sync behaviour.
Posted Apr 22, 2025 - 13:35 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Apr 22, 2025 - 09:15 UTC

Identified

We've identified the cause of the issue impacting PostgreSQL connectors. Our engineering team is currently working on deploying a hotfix to resolve it.
Posted Apr 22, 2025 - 07:35 UTC

Investigating

We are currently investigating the issue.
Posted Apr 22, 2025 - 05:53 UTC
This incident affected: Database connectors (Amazon Aurora PostgreSQL, Azure Database for PostgreSQL, Google Cloud SQL for PostgreSQL, Heroku PostgreSQL, PostgreSQL, Amazon RDS for PostgreSQL).