3rd Party: Qualtrics connection syncs are failing with "HTTP 400 Bad Request" for the "TransactionBatches" endpoint

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We identified an issue affecting the Qualtrics connector, which caused syncs to fail with an HTTP 400 Bad Request error for the transactionBatches endpoint.

Timeline:
This issue began on 2026-05-20 at 08:10 PM UTC and was resolved on 2026-05-21 at 12:30 PM UTC.

Cause:
We have observed that the API calls were failing due to empty skipToken query parameter that we were passing to the API call. We have reached out to the third-party team since this was a new change

Resolution:
A fix has been implemented from our end to omit the skipToken parameter whenever its value is empty or null.
Posted May 21, 2026 - 14:45 UTC

Monitoring

A fix has been implemented from our end and we are monitoring the results.
Posted May 21, 2026 - 11:42 UTC

Update

Syncs are intermittently failing with a "HTTP 400 Bad Request" error for the "TransactionBatches" endpoint due to an issue on the third-party side. We have reached out to third-party support for more details on these failures.

We are also exploring possible workarounds to mitigate the issue in the meantime.
Posted May 21, 2026 - 07:53 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted May 21, 2026 - 06:25 UTC
This incident affected: Support connectors (Qualtrics).