Fivetran: Multiple PostgreSQL connections failing with "Unknown failure: Unhandled classified exception" due to an issue with JsonB binary decoding

Incident Report for Fivetran

Resolved

This incident has been resolved.


Incident Summary

Description:
Some PostgreSQL connectors failed due to a problem with JsonB binary decoding.

Timeline:
This issue began on 21 Aug 2025 at 4:00 PM UTC and was resolved at 8:30  PM UTC.

Cause:
An issue with JsonB binary decoding caused PostgreSQL connections to start failing.

Resolution:
Engineering implemented a hotfix, which restored normal operations.
Posted Aug 21, 2025 - 22:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2025 - 21:12 UTC

Update

Engineering has identified the issue as being caused by a problem with JsonB binary decoding, and are working to resolve it.
Posted Aug 21, 2025 - 20:10 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Aug 21, 2025 - 20:05 UTC
This incident affected: Database connectors (Amazon Aurora PostgreSQL, Azure Database for PostgreSQL, Google Cloud SQL for PostgreSQL, Heroku PostgreSQL, PostgreSQL, Amazon RDS for PostgreSQL).