Fivetran: The Partner Built Destination and Connection Setup is failing with the "Operation timeout" error

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that the setup tests are successful.

Incident Summary
Description:
We identified an issue for the Partner Built Destinations and Connections where the setup is failing with the "Operation timeout" error.

Timeline:
This issue began on March 3rd 2026, at 10 AM UTC and was resolved on March 3rd 2026, at 2:30 PM UTC.

Cause:
Recent changes to the setup workflow caused the issue.

Resolution:
The changes have been reverted to ensure the setup is successful.
Posted Mar 03, 2026 - 14:50 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2026 - 14:09 UTC

Update

Recent changes to the setup workflow caused the issue. A hotfix is being deployed to resolve the issue.
Posted Mar 03, 2026 - 12:41 UTC

Identified

We identified an issue for the Partner Built Destinations and Connections where the setup is failing with the "Operation timeout" error.
Posted Mar 03, 2026 - 12:10 UTC
This incident affected: Systems (Destinations), Database connectors (Convex, PlanetScale), and Marketing connectors (Tracksuit).