Schema tab error: Cannot read properties of of undefined

Incident Report for Fivetran

Resolved

This incident has been resolved. The error no longer appears on the dashboard, and the schema tab should be accessible as usual.

Incident Summary
Description:
We identified an issue with the schema tab in the dashboard being inaccessible.

Timeline:
This issue began on 2025-08-06 at 09:42 AM UTC and was resolved on 2025-08-07 at 09:38 AM UTC.

Cause:
A recent code change related to the Schema tab resulted in an error being thrown when making changes in the tab

Resolution:
A hotfix was deployed to revert the changes and resolve the issue
Posted Aug 07, 2025 - 11:12 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 07, 2025 - 10:35 UTC

Update

A fix has been prepared and is currently being deployed as a hotfix.
Posted Aug 07, 2025 - 05:56 UTC

Update

We have identified the root cause and are currently developing a fix for this issue.
Posted Aug 06, 2025 - 23:13 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 06, 2025 - 22:10 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Aug 06, 2025 - 22:10 UTC
This incident affected: Web Application.