Instagram Business connectors are failing with "Unknown sync failures"
Incident Report for Fivetran
Resolved
This incident has been resolved. We have observed that failure rates have returned to normal levels and affected connectors are syncing successfully.
Posted Jan 03, 2024 - 17:32 UTC
Monitoring
We have now deployed the fix for the "Incompatible metric (total_interactions) with the media" error.

We will continue to monitor all affected connectors until they resume their normal sync functionality.
Posted Jan 03, 2024 - 16:23 UTC
Update
Our engineering team have prepared the fix for the "Incompatible metric (total_interactions) with the media" error.

The fix will be deployed shortly and we will monitor affected connectors.
Posted Jan 03, 2024 - 14:43 UTC
Update
A fix has been deployed to exclude the deprecated fields. This has resolved the initial sync error.

However, we are seeing another error causing the sync failure: "Failure: error: {message:'(#100) Incompatible metric (total_interactions) with the media'"

We are currently working to resolve it.

More Information:
https://developers.facebook.com/docs/instagram-api/changelog/
https://developers.facebook.com/docs/instagram-api/reference/ig-user/insights/
https://developers.facebook.com/docs/instagram-api/reference/ig-media/insights
Posted Jan 03, 2024 - 06:16 UTC
Update
The error seems connected to the recent modification concerning deprecated metrics within the Instagram API. More information: https://developers.facebook.com/docs/instagram-api/changelog/
Posted Jan 02, 2024 - 19:33 UTC
Identified
The connectors are failing with the below error:
"error: {message:'(#100) This metric engagement is no longer supported on version v18+. For a list of alternative metrics, visit https://developers.facebook.com/docs/instagram-api/reference/ig-media/insights.'"

We're triaging the issue further.
Posted Jan 02, 2024 - 19:13 UTC
This incident affected: Marketing connectors (Instagram Business).