Fivetran: Multiple Google Business Profile connectors failing due to rate limit error on Account endpoint

Incident Report for Fivetran

Resolved

This incident has been resolved.


Incident Summary

Description:
Multiple Google Business Profile connections failing due to rate limit error on Account endpoint.

Timeline:
This issue began on 28 Aug at 12:27 PM UTC and was resolved at 9:30 PM UTC.

Cause:
The issue was caused by a bug introduced in a recent code change.

Resolution:
We resolved the issue by rolling back the change, which restored normal functionality.
Posted Aug 28, 2025 - 22:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2025 - 21:33 UTC

Update

We have identified the issue and are working to resolve it.
Posted Aug 28, 2025 - 17:18 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Aug 28, 2025 - 17:15 UTC
This incident affected: Marketing connectors (Google Business Profile).