This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.
Incident Summary
Description: Some SendGrid connectors began failing with a missing "marketing_campaigns.read" permission error. This was due to recent changes in how SendGrid handles API key scopes, which impacted access to marketing-related tables.
Timeline: Issue began on Jul 26, 2025 at 15:00 UTC Resolved on Jul 28, 2025 at 15:30 UTC
Cause: SendGrid began enforcing scope restrictions on API keys, removing marketing_campaigns.read for accounts without Marketing Campaigns enabled. This caused sync failures for connectors trying to access marketing-related tables.
Resolution: We deployed a backend fix to automatically exclude unsupported Marketing tables when the required scopes are missing, allowing affected connectors to sync successfully.
Posted Jul 29, 2025 - 08:33 UTC
Monitoring
We have implemented the fix and are now closely monitoring the results to ensure the issue is fully resolved.
Posted Jul 28, 2025 - 19:14 UTC
Update
We are preparing a fix to exclude all marketing tables in case of scope absence.
Posted Jul 28, 2025 - 11:55 UTC
Identified
Summary: Some SendGrid connectors are currently failing due to missing `marketing_campaigns.read` permissions. This permission is now being enforced by the SendGrid API for non-Event tables. Accounts without Marketing Campaigns enabled cannot grant this scope, leading to sync failures.
Workaround: If your SendGrid account does not use Marketing Campaigns, please go to your connector’s Schema tab and de-select all tables except Event. This will allow the connector to sync successfully.
Next Steps: Our engineering team is actively working on a permanent fix that will automatically exclude unsupported tables for accounts lacking the required permissions.
Posted Jul 28, 2025 - 07:55 UTC
This incident affected: Marketing connectors (SendGrid).