Degraded Performance for Some Fivetran REST API-Triggered Syncs

Incident Report for Fivetran

Resolved

We have resolved this incident.
Posted Jul 24, 2025 - 14:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2025 - 11:30 UTC

Update

A fix has been created for this issue. We are now testing for results to ensure degraded performance is resolved when this fix is applied.
Posted Jul 24, 2025 - 08:40 UTC

Update

We are continuing to work on a fix for this issue.

The common unexpected behaviors seen with this issue are:
- Syncs do not get triggered.
- Airflow pipelines miss acknowledgement.
- The /sync endpoint fails to return a response.

This issue is specific to workflows that use Fivetran's REST API.
Posted Jul 23, 2025 - 21:07 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jul 23, 2025 - 20:45 UTC
This incident affected: Fivetran API.