Fivetran: Setup tests for SharePoint connections using the Merge Mode option are failing for both new and existing connectors with the following error: "Validating shared URL from SharePoint: Please provide correct URL, it is empty or null"

Incident Report for Fivetran

Resolved

We have resolved the incident and confirmed that setup tests for SharePoint connections using Merge Mode are now working as expected.

Incident Summary

Description:
SharePoint connections configured with Merge Mode were failing during setup with the following error message:
“Validating shared URL from SharePoint: Please provide correct URL, it is empty or null.”

Timeline:
Incident start date: May 21, 2025 – 05:00 UTC
Incident end date: May 21, 2025 – 07:30 UTC

Root Cause:
The issue was caused by a bug introduced in a recent code change.

Resolution:
We resolved the issue by rolling back the change, which restored normal functionality.
Posted May 21, 2025 - 08:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 21, 2025 - 07:23 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted May 21, 2025 - 05:27 UTC
This incident affected: File connectors (SharePoint).