Fivetran: SDK connections are failing with "Python Code Throwing Error" on dashboard due to an issue in reading the credentials

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.

Incident Summary
Description:
We have identified an issue with SDK connections, causing failure with "Python Code Throwing Error" on the dashboard due to an issue in reading the credentials

Timeline:
This issue began on 19 Nov 12:30 AM UTC and was resolved on 19 Nov 7:15 AM UTC

Cause:
There was a recent change in the connector code, which caused a bug in reading the credentials.

Resolution:
Hotfix has been deployed to revert the changes, and the connections are syncing successfully after the fix.
Posted Nov 19, 2025 - 06:35 UTC

Monitoring

Hotfix has been deployed, and the connections are now recovering. We will continue to monitor.
Posted Nov 19, 2025 - 05:19 UTC

Update

We have identified that the issue is related to a recent change which caused a bug in reading the credentials. A hotfix has been created to revert the changes. We will provide another update once the hotfix is deployed
Posted Nov 19, 2025 - 05:04 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Nov 19, 2025 - 04:50 UTC
This incident affected: Function connectors (Connector SDK).