Google Ads: Sync Failure - Unknown Failure

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We have identified some Google Ads connectors are failing with an "Unknown Failure". There are `java.util.NoSuchElementException` errors as well when attempting to change configuration.

Timeline:
This issue began on Friday, 25 Apr at 15:30 PM UTC and was resolved on Saturday, 26 Apr at 3:00 AM UTC.

Cause:
The Google API Library returned null values to our requests resulting in an unknown failure.

Resolution:
The fix has been implemented and all affected connectors have returned to normal functionality.
Posted Apr 26, 2025 - 10:52 UTC

Update

The fix has been deployed to all the integrations, and the syncs are getting successful now. We will continue to monitor.
Posted Apr 26, 2025 - 04:28 UTC

Monitoring

We have deployed a fix for this issue: "Sync Failure - Unknown Failure", where the Google API Library was updated without notice. This caused the Google Ads API to reject our requests with an unknown failure and our API calls have been changed accordingly to prevent further errors.

The fix has not yet deployed to all integrations. We will continue to monitor all affected connectors until they resume their normal sync functionality.
Posted Apr 25, 2025 - 23:05 UTC

Identified

We have identified the issue and are working on a solution. We are still looking in to why only specific connectors were affected.
Posted Apr 25, 2025 - 19:43 UTC

Investigating

We have identified some Google Ads connectors are failing with an "Unknown Failure". You may also see `java.util.NoSuchElementException` errors when attempting to change configuration.

We are actively investigating the cause of these failures.
Posted Apr 25, 2025 - 17:36 UTC
This incident affected: Marketing connectors (Google Ads).