Transformation failed | "Oops, You just submitted a request that we don't support"
Incident Report for Fivetran Inc
Postmortem

Root Cause:

The Kubernetes cluster which runs transformations had hit its memory resource limit as a result of our operations team installing new monitoring software.

Timeline:

12/03/2020 ~2:00 PM PDT - Monitoring software was installed and memory started to climb.

12/03/2020 ~4:00 PM PDT - Memory on the Kubernetes cluster was increased and we saw transformations being to complete successfully.

Resolution:

We setup our clusters to run nodes with 8GB of memory. This not only gives plenty of room for the transformation running and the other agents that run, but also lets the transformation running actually hit its 4GB limit.

Posted Dec 04, 2020 - 00:45 UTC

Resolved
Transformations failed between the hours of of 2PM and 4PM PDT.

When clicking on the transformations tab in the interface, the following error was seen:

"Oops. You just submitted a request that we don't support. Reach out to support to help troubleshoot further."
Posted Dec 03, 2020 - 22:00 UTC