3rd Party: Some HubSpot connection syncs are failing with an HTTP 477 RefreshCredentials error.

Incident Report for Fivetran

Resolved

This incident has been resolved, and we have observed that the sync is now completing successfully.

Incident Summary
Description:
We have identified an issue where some HubSpot connector syncs are failing with the error

Failed to sync 1 endpoint(s) with error: {CAPTURE_DELETES_USING_WEBHOOKS=com.fivetran.platform.interfaces.security.credentials.RefreshCredentialsException: HTTP 477 }

Timeline:
The issue began on March 14, 2026, at 09:01 UTC and was resolved on March 14, 2026, at 10:43 UTC.

Cause:
The recent migration of the Fivetran public app by HubSpot has caused the issue.

Resolution:
A fix has been implemented to resolve the issue.
Posted Mar 14, 2026 - 12:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2026 - 10:45 UTC

Update

Recent migration of the Fivetran public app by HubSpot has caused the issue. A hotfix is being deployed to resolve the issue.
Posted Mar 14, 2026 - 10:15 UTC

Identified

We identified an issue with the HubSpot Connections where the syncs are failing with an HTTP 477 RefreshCredentials error.
Posted Mar 14, 2026 - 09:00 UTC
This incident affected: Sales connectors (HubSpot).