Fivetran: Few Salesforce Marketing Cloud Connections are failing

Incident Report for Fivetran

Resolved

This incident has been resolved. We have confirmed that instance rates have returned to normal, and Salesforce Marketing Cloud connections are now syncing successfully.

Incident Summary:
Some connectors with the MobilePushDetailReport table enabled were failing due to an issue with the backward sync process.

Description:
The failure was caused by an unexpected condition in the backward sync handling for the MobilePushDetailReport table. This caused certain connectors to fail during sync operations. Only connectors with MobilePushDetailReport enabled were affected.

Timeline:

Incident Start time: 2025-10-24 11:10 UTC
Incident End time: 2025-10-24 13:15 UTC

Root Cause:
An update to the backward sync handling triggered an issue for connectors with MobilePushDetailReport enabled, which caused sync failures.

Resolution:
The fix has been applied, restoring normal backward sync operations. Affected connectors are now syncing successfully.
Posted Oct 24, 2025 - 13:20 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 24, 2025 - 13:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2025 - 13:00 UTC

Identified

We have identified that a few salesforce marketing cloud connections are failing with the error:
Failed to sync 1 endpoint(s) with error: {MobilePushDetailExtractReport=java.time.DateTimeException: Invalid value for Year (valid values -999999999 - 999999999): 1000000000}
Posted Oct 24, 2025 - 11:10 UTC
This incident affected: Marketing connectors (Salesforce Marketing Cloud).