Multiple Reddit Ads connections failing while connecting to the Reddit Ads API

Incident Report for Fivetran

Resolved

This incident has been resolved. We have confirmed that instance rates have returned to normal, and Reddit Ads connections are now syncing successfully.

Incident Summary

Description:
Reddit Ads connections were failing while connecting to the Reddit Ads API.

Timeline:
The issue began on November 04, 2025, at 22:04 UTC and was resolved on November 05, 2025, at 18:22 UTC.

Cause:
Access token requests were failing with a 403 Forbidden error.

Resolution:
We resolved the issue by making a few changes to our Reddit App.
Posted Nov 05, 2025 - 18:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 05, 2025 - 18:40 UTC

Identified

We have identified that when the connection attempts to refresh the access token using the refresh_token grant type, the source is returning a 403 Forbidden error. This is causing syncs and setup tests to fail after five retry attempts.

We have contacted Reddit support to investigate and resolve the issue. Further updates will be provided as soon as more information becomes available.
Posted Nov 05, 2025 - 13:20 UTC
This incident affected: Marketing connectors (Reddit Ads).