Fivetran: Asana connector sync failing with Cannot read field "gid" error

Incident Report for Fivetran

Resolved

We've resolved the issue. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully.

Incident Summary:
Asana connector sync failing with Cannot read field "gid" error

Description:
Starting June 20, 2025, Asana connector sync failing with the following error
Cannot read field "gid" because the return value of "com.fivetran.integrations.asana.model.Story$Heart.user()" is null

Timeline:
Incident Start time: 2025-06-20 5:15 UTC Incident End time: 2025-06-20 10:35 UTC

Cause:
The issue was triggered by a recent update that introduced an edge case where certain conditions were not being handled as expected, resulting in an error.

Resolution:
We’ve implemented an additional validation check to handle this scenario gracefully and prevent the error from occurring in the future.
Posted Jun 20, 2025 - 10:35 UTC

Monitoring

Our engineering team has raised a hotfix for the issue, which has been deployed successfully. We will continue to monitor the connector syncs
Posted Jun 20, 2025 - 07:35 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Jun 20, 2025 - 05:15 UTC
This incident affected: Productivity connectors (Asana).