Fivetran : Few Amazon Selling partner connections are failing for the all_listings_report

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.

Incident Summary
Description:
We identified an issue for Amazon Selling partner connections which resulted in syncs failing with a "Cannot invoke "com.fivetran.platform.interfaces.connector.SharedContext.safeFileBufferFactory()" because "this.sharedContext" is null" error.

Timeline:
This issue began on April 8, 2026 at 11:00 AM UTC and was resolved on April 8, 2026 at 2:30 PM UTC.

Cause:
A bug has been introduced on our end due to which we started hitting context being null error .

Resolution:
A fix has been implemented on our end to mitigate the issue.
Posted Apr 08, 2026 - 15:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2026 - 14:07 UTC

Identified

We have identified that the connections are failing with the below error

all_listings_report endpoint sync failed with error: Cannot invoke "com.fivetran.platform.interfaces.connector.SharedContext.safeFileBufferFactory()" because "this.sharedContext" is null
Posted Apr 08, 2026 - 12:50 UTC
This incident affected: Sales connectors (Amazon Selling Partner).