Description: We have identified an internal issue affecting a subset of Jira connectors using OAuth1 authentication. This issue is causing sync failures for impacted connectors
Timeline: Issue started on December 17, 04:30 AM UTC and Resolved on December 17, 7:50 AM UTC
Cause: The issue is a field initialization order bug in the JiraApiBase constructor. The sharedContext field is assigned after the buildClient() method is called, but buildClient() triggers a chain of method calls that eventually requires sharedContext to be initialized.
Resolution: The initialisation order was changed with a fix.
Posted Dec 17, 2025 - 08:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 17, 2025 - 07:28 UTC
Update
We have identified an internal issue affecting a subset of Jira connectors using OAuth1 authentication. This issue is causing sync failures for impacted connectors. Our engineering team is actively working on a fix.
Posted Dec 17, 2025 - 06:29 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Dec 17, 2025 - 06:15 UTC
This incident affected: Engineering connectors (Jira).