Resolved: We’ve resolved the issue. We have observed that instance rates are returning to normal levels, and affected connectors are syncing successfully
Incident Summary Description: We identified an issue with Twitter. Twitter connectors were failing with the error: Unable to add new jobs because the number of waiting jobs didn't reduce after 900 seconds
Timeline: Incident Start time: 2025-05-23 04:22 UTC Incident End time: 2025-05-26 08:02 UTC
Root Cause: The issue was on the Twitter side.
Resolution: We skipped the problematic endpoints in case of failed async jobs. Now, there have been no failures for more than 24 hours.
Posted May 26, 2025 - 08:02 UTC
Update
We are continuing to observe failed sync jobs when syncing reports. A workaround is in place, and operations remain stable. While there is no official update from the source, we are closely monitoring the situation.
Posted May 25, 2025 - 10:09 UTC
Update
We’ve observed a significant decrease in failed Twitter connections and no new failures in the past 6 hours. Recent adjustments have reduced the impact, and the system is showing signs of recovery. We’ll continue monitoring closely.
Posted May 24, 2025 - 20:42 UTC
Update
We’ve observed improvements in system performance and a reduction in related errors. Our team is continuing to monitor the situation to ensure stability.
Posted May 24, 2025 - 15:52 UTC
Update
We are continuing to monitor for any further issues.
Posted May 24, 2025 - 14:14 UTC
Update
Twitter syncs remain impacted by API errors. We're actively managing the situation to minimize disruption.
We’ll provide updates as we learn more and restore full service as soon as possible.
Posted May 24, 2025 - 14:09 UTC
Monitoring
We are currently experiencing sync issues from Twitter due to a widespread outage on their platform. The source service is returning a 503 (Service Unavailable) response, which is preventing successful data retrieval on our end.
Our systems remains operational, and we are actively monitoring the situation.
Posted May 24, 2025 - 05:34 UTC
Investigating
We are currently experiencing issues fetching metadata entities due to a 503 response from the source service. Our team is actively working to resolve the issue and restore full functionality.
Posted May 23, 2025 - 13:49 UTC
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted May 23, 2025 - 09:37 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted May 23, 2025 - 04:22 UTC
This incident affected: Marketing connectors (Twitter Organic).