All connectors have now recovered from the initial error condition. If you have a Postgres connector that is continuing to fail, please open a support ticket so we can investigate further.
Posted Nov 07, 2025 - 23:21 UTC
Update
We are continuing to see connectors recover. Monitoring is ongoing to ensure all failing connectors recover successfully.
Posted Nov 07, 2025 - 20:21 UTC
Update
We are continuing to see a steady increase in recovery and we are still monitoring syncs and completion rates.
Posted Nov 07, 2025 - 18:28 UTC
Update
We are seeing a steady increase in recovery and we are still monitoring syncs and completion rates.
Posted Nov 07, 2025 - 16:49 UTC
Update
We observed that the connections are still recovering. We will continue to monitor sync performance and completion rates until full restoration.
Posted Nov 07, 2025 - 14:36 UTC
Update
We are continuing to observe syncs recovering and will actively monitor sync performance and completion rates. We will provide the next update in the next hour.
Posted Nov 07, 2025 - 11:52 UTC
Update
We have observed that syncs are starting to get recovered successfully. We are continuing to closely monitor sync performance and completion rates and will update in the next hour.
Posted Nov 07, 2025 - 10:49 UTC
Update
We have identified and deployed a fix for the issue, and we expect affected connectors to recover automatically. Our team is closely monitoring the sync performance and will provide a further update in 30 minutes.
Posted Nov 07, 2025 - 10:16 UTC
Monitoring
A fix has been implemented, We are monitoring syncs recovering and will provide another update in 30 minutes.
Posted Nov 07, 2025 - 09:35 UTC
Update
We are continuing to investigate the issue affecting Teleport-based PostgreSQL and Snowflake connections, and we are closely monitoring.
Posted Nov 07, 2025 - 04:42 UTC
Identified
All connections except Teleport-based PostgreSQL and Snowflake have now recovered. We are actively investigating the issue affecting Teleport-based PostgreSQL connections and continue to monitor.
Posted Nov 07, 2025 - 04:42 UTC
Monitoring
The system has been rolled back to a previously built version, and error rates are improving. We continue to closely monitor performance and stability.
Posted Nov 07, 2025 - 03:45 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 07, 2025 - 02:55 UTC
Identified
The issue has been identified and we are working to resolve it.
Posted Nov 07, 2025 - 00:00 UTC
This incident affected: Database connectors (PostgreSQL).