Fivetran: Netsuite syncs are delayed

Incident Report for Fivetran

Resolved

This incident has been resolved. We have observed that instance rates are returning to normal levels and affected connectors are syncing successfully.
Posted Oct 05, 2023 - 21:47 UTC

Monitoring

After further discussions and investigations with Netsuite's team, we were able to narrow down the issue to the cloud provider on which the jobs were hosted. We have implemented a fix for the same and started a new sync for it to take effect. We are actively monitoring the affected connectors to understand if it has helped.
Posted Oct 05, 2023 - 13:10 UTC

Update

We are continuing to work closely with Netsuite via defect #736104 related to this issue. The root cause has not been identified yet, but they have assured us that they are continuing their investigation.
Posted Oct 04, 2023 - 16:08 UTC

Update

Netsuite has not been able to identify the root cause of the long-running queries but was finally able to reproduce the behavior internally. They informed us that they have a team of people who have been working on this specific issue over the last two weeks and will continue to do so until resolution.

We are continuing to work with their team.
Posted Sep 27, 2023 - 17:23 UTC

Update

Netsuite is continuing to work on defect #736104 related to this issue. We will continue to follow up until the issue is resolved.
Posted Sep 25, 2023 - 08:29 UTC

Update

Netsuite is continuing to work on this issue. We have requested another update from them.
Posted Sep 22, 2023 - 21:14 UTC

Update

Netsuite is continuing to work on this issue. We have requested another update from them.
Posted Sep 22, 2023 - 14:54 UTC

Update

Netsuite is continuing to work on this issue and we have followed up for an update with them.
Posted Sep 21, 2023 - 16:11 UTC

Update

The query timeouts for the affected connectors as a temporary workaround have been deployed as of 7 AM UTC this morning.
Netsuite has assured us that they are still working on this defect #736104.
Posted Sep 20, 2023 - 17:39 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 20, 2023 - 17:32 UTC

Update

We have implemented query timeouts for the affected connectors as a temporary workaround. This timeout will throw a task if a specific SQL query does not receive a response from Netsuite on the Fivetran dashboard and will terminate the ongoing sync instead of running continuously for 24 hours.

Netsuite is still working on this defect #736104 and we are continuing to share the requested information with them in order for them to resolve this on their side ASAP.
Posted Sep 19, 2023 - 14:50 UTC

Update

We are actively monitoring for updates from the Netsuite Support Ticket #736104.

To implement an interim solution from the Fivetran side, we are trying different mechanisms to add timeouts for the queries from our side to stop the syncs from getting stuck.
Posted Sep 18, 2023 - 12:24 UTC

Update

Netsuite's QA engineering team is continuing to investigate defect #736104 with a high priority and we will continue to provide regular updates shared by their team.
Posted Sep 15, 2023 - 21:50 UTC

Update

We are continuing to work with Netsuite on this issue and have their QA team looking into this. We have also requested this to be further escalated with Netsuite and will regularly share updates.
Posted Sep 15, 2023 - 09:50 UTC

Update

On September 12th, we identified that some Netsuite syncs were getting stuck and terminating after 24 hours. We raised an issue with Netsuite. Netsuite conducted an investigation and filed an internal defect with an urgency level of U3. We will continue to liaise with them and do what we can to assist with getting this issue resolved.
Posted Sep 14, 2023 - 23:05 UTC

Identified

The issue has been identified and we are working to resolve it.
Posted Sep 14, 2023 - 22:51 UTC
This incident affected: Finance connectors (NetSuite SuiteAnalytics).